Arma III - Altis life RPG

Posting this here for reference to fix in game voice:

[code]control panel
see want sound devices you have
recording (yes second one to the right)
pick headset if thats what you use or microphone if thats what you use
set as default run though the properties tab

set recording audio input device or auto detect


Start Arma 3
microphone auto adjust [/code]

Those of you who have Arma III come check out the altis life RPG, it’s quite fun.

Here’s a quick start guide to Altis Life:

I’ve been playing on the Neutral Gaming server.

It’s been customized with a South African flavour, cops have the correct SAPS uniform with branded vehicles and things like Nkandla, sabc, cap union mate etc. all exist ingame.

Just two jobs and I can make enough cash to make a gang, call it something like ‘Desert Kings’ and obviously deal in illegal activities.

Here’s a video of some guys robbing the federal reserve. Pity we couldn’t see the guy actually breaking in and stealing the cash, They got away with $365 000

Store vehicle:

Mouse-wheel over the Garage NPC, and you can store your vehicle in the garage.
It costs $350 to retrieve it.


Just drive up next to a fuel pump, look at the pump and you can refuel. No apparent cost. [s]It seems this may also repair vehicles.[/]

For what it’s worth, I did some delivery jobs. First one was to DP19 which is in the middle of the island - $23k and some change. Took one from there to DP20 which is at the east-ass end of the island - $25k. Took one from there to DP17 which is a short hop - $4k. A long drive, some of it in absolute pitch darkness, thanks to me running in to a wall while looking at the map and breaking the quad’s headlights.

The sound setup: steam opens the windows default stuff. Mine was set to line in, belch. TS works fine if I select mic, but steam & arma … noooo we want to use default devices.

So that can of fuel from PnP is probably for malicious use, goody :slight_smile:

(press T to access your car/bike/trucks trunk, useful for storing items)

I tried to buy a toolkit to repair my bike but it states i dont have space? My inventory was empty. I’ve yet to figure out how to fix a bike.

Buy a big bag, about 5k for the really big one. When I bought mine, it gave the same message about not having space, but when I went to third person view, I saw it was equipped. /shrug

Was able to buy a toolkit then, and repair.

1 Like

My ban is being investigated, should be fine soon.

Ok, that’s cool.

They’ve stopped talking to me, still banned. Dunno whats going on :frowning:

That’s not cool.

Bleh. Just for the hell of it, I’ve been trying to get an Altis Life server running (on Linux). This is a huge cramp, as documentation for this is rather lacking, and you get sent hither and thither to read documents that don’t make a lot of sense at first read, and for the most part, you have to translate the windows related docs to the linux environment. It’s not terribly difficult though.

The biggest hurdle has been getting to compile. The arma3 server is 32bit, therefore the library needs to be 32bit. There’s documentation for it which sets up a whole chroot 32bit environment to compile it. Since I didn’t want to bugger up my server, I set up the chroot environment within a VM, although using the version of linux I’m running on the server, rather than the latest that the documents are geared for. I had some headaches, particularly with getting the correct version of libboost-dev installed, but once I got that right, I managed to get a compiled version of Copied the library to the server, launched arma, and it eventually told me (after connecting with a client) that extDB has not been loaded. I figured it’s probably because it’s dynamically linked and doesn’t have all the right libraries. I was right. So I manually copied all the required libraries over to the server, sticking them in /usr/local/lib (where there wasn’t much else to cause trouble), and tried launching the server again. So far so good. Connected with the client, got in and “Host has gone away”. Ugh. Core dump.

I figure the problem is that some of the libraries that already detected on the server are actually 64bit, hence the core dump.

If I could get the shared library to compile statically (ie include the components it needs within it instead of dynamically linking at runtime), my problem would be solved - however I haven’t found a scenario where you can compile a shared library statically - and of course extDB uses cmake which I’m not familiar with at all. Apparently extDB was the devs first c++ project, which could explain the strange way (to me) that it is built.
If the library is compiled statically - that is with a .a extension, I’m not sure if the arma3 server binary will pick it up.

Alternatively - and this seems to be the method that is in mind in some of the documentation I’ve read - not only do you set up the chroot environment for compiling extDB, but you should run the server under it as well. This will apparently do away with the problems I’ve been experiencing, however it seems a bit counterproductive to run the server like this. It will also make it extremely problematic to update the script files etc. :frowning:

If the 32bit arma3 server can run on a 64bit system, why the hell can’t

This might help me later: c - Possible to build a shared library with static link used library? - Stack Overflow

Also might help: The Sorry Scheme of Things Entire: Linking static libraries into a shared library

Looks like the extDB dev is working on a static build. It appears that he was having problems building one of the dependencies statically, but seems to have figured it out. [s]He reckons he should have a static build soon![/]

I note that there is already a static build in the dev branch. I’ll grab it and test it later.

1 Like

Excuse the graphics, laptop gpu not very powerful.

1 Like

Woo! I finally got it running! :smiley:

Now to add some customizations etc.

1 Like


1 Like

Altis life debug console commands:

Random weather: Looking for an Elite RP experience? Erie RP is the place to be! - English Server - Altis Life RPG
Surrender action:
Wanted list:
Towing: Having Some Issues - extDB3 - Altis Life RPG
Saving character position: Set level on rebel - Solved - Altis Life RPG
rob shops, fuel stations etc: UAV Operators [Solved] - Solved - Altis Life RPG
Dogs (for cops) : Error in Expression - Solved - Altis Life RPG
Stolen car sounds: Call cop level on vehicle texture - Solved - Altis Life RPG
Vehicle paint shops : Making a GUI New Dialog - Solved - Altis Life RPG
Dynamic gold spawns + hunting: Error with insertrequest - Solved - Altis Life RPG
Grapes, moonshine, wine : [Tutorial] Hidding markers from police - 4.x - Altis Life RPG
Lock & unlock sounds:
Status bar : [KICK] Marijuana - Server Setup and Configuration - Altis Life RPG
Crystal meth :
Adding more vehicles:

Cool. It’s going to take quite a bit of time to do these mods.

So if anyone was wondering, Flea & I have done some pretty cool mods to our experimental server.

We’ve done 68 commits to the repository so far.


You can hotlink your repo to %userprofile%\documents\arma 3 -other profiles\Insanityflea\missions\altis_life.Altis

Then fire up arma 3 and use the in game editor to view the mission (can add units and stuff)

How do you think I moved the spawn? :stuck_out_tongue:

1 Like

That would’ve help me to move the garage instead of editing the damn coords. /sigh.