ArcheAge - Rant here


#61

Every time someone mentions the family:


#62

Well, now we finally have a guild: Breaking Winds


#63

http://forums.archeagegame.com/showthread.php?11966-Silent-Forest-Ancient-Necropolis-Secret-Quest

Silent Forest Ancient Necropolis Secret Quest

Found a dead body, next to a Moonlight Anvil, on the second tier of the large central structure in the Ancient Necropolis. Examining the body gave a note, which says,

“I’ve assembled all of the pieces, but still can’t decipher what they’re trying to say. My time has ended, but whoever finds
this letter, please do the honor of finishing my work. Uncover the secrets of the royal tomb that I could not”

Tried to use the anvil, but it says, “Not enough Purified Blade”. Couldn’t do anything with it, so headed down into the next tomb, just North of this main central structure. Inside I found another item I could interact with. Upon examination it says,

“I found purified all five cursed items, but it’s still not over. What else do I need? The five items, and…I have to get moving. I
don’t even have time to think, just act.”

Looking at the map, you can see that there are five tombs surrounding the central structure. So I still started killing the the Cursed Warlocks in here until they dropped a Cursed Spellbook. Moving counter clockwise from here, i killed the mobs in each tomb until I had received a cursed item from each of the five; Cursed Spellbook, Cursed Blade, Cursed Wolf Claw, Cursed Armor Piece, and Cursed Fog. Also noticed that in each of these 5 tombs, there is a large Royal Tomb door that you can interact with, but says that you need a Royal Tomb Key.
In the last tomb, the one with the Cursed Mistfiends and the level 30 named mob, there is another item you can interact with, which says,

“I found it! I found a cursed item on a smokefiend slain by a traveler. At first, it seemed to have little value, but then I
remembered something. A certain lake can purify curses…but only at it’s absolute center. I don’t have much time. I must get
there before the curse spreads to me.”

Taking all five of the cursed items, I swam to the bottom of Soundless Lake, directly in the center. This is the same place another quest in the zone takes you, not long before moving on to the next zone. At the bottom of the lake, you find a large circular alter-type structure. Use the cursed items while down there and it will purify all five of the them. Once purified, head back to the large central structure in Ancient Necropolis and use the anvil. This will consume all five purified items and give you a Royal Tomb Key. I used the door in the tomb directly north of where I was, but figure it will work in any of them. The door disappears and leads down into another area with level 35 mobs. They had 8-11k hp, so be prepared. After killing my way down, you come across a large central chamber, and inside is Umbra’s Spirit. A very large, 35k hp, mob. Am doing this all solo, and guildless, so no back-up to call on. So if anyone kills him, let me know if drops anything interesting.


#64

Loving it.


#65

Here’s my mailbox today:


#66

Can someone help interpret this for me?

I did a tracert to the ArcheAge server. I can see where the hold up is, but I can’t tell what might be causing it…


#67

Rather do a pathping. The timeout is caused by something blocking the ICMP protocol and doesn’t really indicate an issue.


#68

Did you know there’s an in-game wiki?

Click the gear icon on the bottom right.


#69

Which you have to login to read… kind of defeats the purpose if you ask me :stuck_out_tongue:


#70

Any way of running this game fullscreen, windowed, but border-less? Alt tabbing out all the time sucks.


#71

The other day, I managed to get some crime points (oops). So in order to clear them, you need to do some penance quests. I only had 3 crime points, and this particular penance quest removes 30 crime and infamy points. I could’ve just left it. You only get hauled in to court when you have >50 crime points anyway, but I wanted to continue doing jury duty.

So I made my way to the lvl40 PVP area (I’m lvl 34 at the moment).

It’s quite pretty, but I encountered a bug.

Shortly after launching off this ledge, aimed directly at the area I needed to go,my glider suddenly closed.
It was very strange, because I had only just launched, and there was nothing in the area to knock me off. Anyway, I decided to continue running, only to discover that I could not leave the small area I was in. I turned my camera, only to discover I was stuck inside a rock, yet again.

You can see the vegetation sticking out of the rock, and at the bottom left is a bit of my toon’s body. Fortunately there’s a skill called ‘Escape’ which is kind of like /stuck. Unfortunately it can take some time to execute - it usually makes you wait around 120 seconds, although you have the option to cancel it… which also happens to set off the 30 minute cooldown. Yes, I’ve been trapped before and discovered that the hard way, fortunately that time Flea was nearby with his mount which allowed me to get on it and out of the glitch. This time, however, there was nobody nearby. So I activated the escape, which would teleport me to the nearest temple after 120 seconds. Unfortunately, while there was still 30 seconds left, the mountain goat in the picture there decided to aggro me and started smacking the snot out of me. And while this skill is counting down you can’t do anything, except for cancelling it and activating the 30 minute cool down. So I was screwed either way :worried:. I hoped to survive as my hit points dwindled away as the timer counted towards zero… :sweat: but alas, with 3 seconds left on the timer, the goat killed me. I kissed 7000 XP goodbye. The stupid priestess only gave me 5000 XP back. :rage:


#72

Im sorry but this is really funny


#73

We helped Flea build his first boat.

Here we are going around the tip of Solis Headlands, heading up to where our gardens are.


Note the cool water effect as you lift your camera out the water.

Sailing in to the sun. You can just make out an unmarked player housing island in the distance. There seems to be quite a few around.

That’s the other side of an interesting area where we did some questing a few levels back. I am manning the harpoon.

You would be inclined to think that this is a very strange angle for the ship to be at. You would be correct. I was using the harpoon to drag us up the side of a cliff. Unfortunately they don’t make ropes quite like they used to.


#74


#75

That is pretty freaking awesome!


#76

I’ll copy it from rizzy on the weekend


#77

This is one thing that irritates me severly about ArcheAge.

But first, play this video, put the volume VERY loud. As loud as it can go. Bang your head, it’s just AWESOME!

I grew up with this song. It saddens me that Malcolm Young has dementia now.
I digress. AA has thunderstruck logs. Thunder cannot strike. It’s a noise. Lightning strikes, not thunder. :rage:


#78

Sonic boom?


#79

Every time I see it mentioned in faction chat i’m like “nhhha nahhh naaahhh nah, THUNDER!”


#80

I think you can get struck by thunder, when it’s really loud it kinda hits you. You can be dumbstruck by thunder?